読者です 読者をやめる 読者になる 読者になる

たぷつきません

おなかがでてきた。もうたぷついてるやん。

1.2.6だとローカル開発環境が動かない。

以下の例外が出て起動できない。

java.lang.AbstractMethodError: com.google.appengine.tools.development.DevAppServerImpl.getUserPermissions()Ljava/security/Permissions;

情報漁ってみたら、

  • 1.2.5で作成したプロジェクトから切り替えただけだと動かない
  • Configurationにjavaagent追加しないとならない
  • 1.2.6を新規作成して1.2.5のプロジェクトを持って行けば動く

…などがあったけど全部試してみても動作しない。困った。1.2.6の新規作成の違いは最初からRun Configurationが作られるかどうかぐらいしか差が無いように見えるのに。うーむ。

http://groups.google.com/group/google-appengine-java/browse_thread/thread/3497eec1c4908bbf

追記

その後、id:cynipeさんから、appengine-java-sdk-1.2.6/lib/agent/appengine-agentimpl.jarをWEB-INF/libに配置すれば?というアイデアをもらったが、これもうまくいかなかった。うーむ。